networkx : install networkx ,pygraphviz and matplotlib (Debian)

hdknr@LennyOne:~/djopenid/djopenid$ sudo pip install networkx

Downloading/unpacking networkx
  Running setup.py egg_info for package networkx
    warning: no previously-included files matching ‘*~’ found anywhere in distribution
    warning: no previously-included files matching ‘*.pyc’ found anywhere in distribution
    warning: no previously-included files matching ‘.svn’ found anywhere in distribution
    no previously-included directories found matching ‘doc/build’
    no previously-included directories found matching ‘doc/source/reference/generated’
    no previously-included directories found matching ‘doc/source/examples’
    no previously-included directories found matching ‘doc/source/static/examples’
    no previously-included directories found matching ‘doc/source/templates/gallery.html’
Installing collected packages: networkx
  Running setup.py install for networkx
    warning: no previously-included files matching ‘*~’ found anywhere in distribution
    warning: no previously-included files matching ‘*.pyc’ found anywhere in distribution
    warning: no previously-included files matching ‘.svn’ found anywhere in distribution
    no previously-included directories found matching ‘doc/build’
    no previously-included directories found matching ‘doc/source/reference/generated’
    no previously-included directories found matching ‘doc/source/examples’
    no previously-included directories found matching ‘doc/source/static/examples’
    no previously-included directories found matching ‘doc/source/templates/gallery.html’
Successfully installed networkx

hdknr@LennyOne:~/djopenid/djopenid$ sudo pip install matplotlib
Downloading/unpacking matplotlib
  Downloading matplotlib-0.91.1.tar.gz (3.9Mb): 3.9Mb downloaded
  Running setup.py egg_info for package matplotlib
    ============================================================================
    BUILDING MATPLOTLIB
                matplotlib: 0.91.1
                    python: 2.5.2 (r252:60911, Jan  4 2009, 17:40:26)  [GCC
                            4.3.2]
                  platform: linux2

    REQUIRED DEPENDENCIES
                     numpy: no
                            * You must install numpy to build matplotlib.
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 274, in main
    self.run(options, args)
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 431, in run
    requirement_set.install_files(finder, force_root_egg_info=self.bundle)
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 1843, in install_files
    req_to_install.assert_source_matches_version()
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 1516, in assert_source_matches_version
    version = self.installed_version
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 1508, in installed_version
    return self.pkg_info()[‘version’]
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 1476, in pkg_info
    data = self.egg_info_data(‘PKG-INFO’)
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 1434, in egg_info_data
    filename = self.egg_info_path(filename)
  File "/usr/lib/python2.5/site-packages/pip-0.4-py2.5.egg/pip.py", line 1458, in egg_info_path
    assert len(filenames) == 1, "Unexpected files/directories in %s: %s" % (base, ‘ ‘.join(filenames))
AssertionError: Unexpected files/directories in /home/hdknr/djopenid/djopenid/build/matplotlib/pip-egg-info:

Storing complete log in ./pip-log.txt

hdknr@LennyOne:~/djopenid/djopenid$ sudo pip install numpy

(ログいっぱい)

    gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions build/temp.linux-i686-2.5/numpy/random/mtrand/mtrand.o build/temp.linux-i686-2.5/numpy/random/mtrand/randomkit.o build/temp.linux-i686-2.5/numpy/random/mtrand/initarray.o build/temp.linux-i686-2.5/numpy/random/mtrand/distributions.o -Lbuild/temp.linux-i686-2.5 -o build/lib.linux-i686-2.5/numpy/random/mtrand.so
    Creating build/scripts.linux-i686-2.5/f2py
      adding ‘build/scripts.linux-i686-2.5/f2py’ to scripts
    changing mode of build/scripts.linux-i686-2.5/f2py from 644 to 755
    changing mode of /usr/bin/f2py to 755
Successfully installed numpy

hdknr@LennyOne:~/djopenid/djopenid$ sudo pip install matplotlib

(ログいっぱい)

============================================================================

running install

running build

running build_py

copying lib/matplotlib/mpl-data/matplotlibrc -> build/lib.linux-i686-2.5/matplotlib/mpl-data

copying lib/matplotlib/mpl-data/matplotlib.conf -> build/lib.linux-i686-2.5/matplotlib/mpl-data

running build_ext

building ‘matplotlib.ttconv’ extension

gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/local/include -I/usr/include -I. -I/usr/include/python2.5 -c ttconv/pprdrv_tt2.cpp -o build/temp.linux-i686-2.5/ttconv/pprdrv_tt2.o

cc1plus: warning: command line option "-Wstrict-prototypes" is valid for Ada/C/ObjC but not for C++

In file included from ttconv/pprdrv_tt2.cpp:39:

ttconv/truetype.h:50: error: ISO C++ forbids declaration of ‘FILE’ with no type

ttconv/truetype.h:50: error: expected ‘;’ before ‘*’ token

error: command ‘gcc’ failed with exit status 1

—————————————-
Command /usr/bin/python -c "import setuptools; __file__=’/home/hdknr/djopenid/djopenid/build/matplotlib/setup.py’; execfile(‘/home/hdknr/djopenid/djopenid/build/matplotlib/setup.py’)" install –single-version-externally-managed –record /tmp/pip-xDZsOK-record/install-record.txt –install-headers /home/hdknr/djopenid/djopenid/lib/include failed with error code 1
Storing complete log in ./pip-log.txt

 hdknr@LennyOne:~/djopenid/djopenid$ sudo pip install pygraphviz
Downloading/unpacking pygraphviz
  Could not fetch URL http://networkx.lanl.gov/wiki/download (from http://pypi.python.org/simple/pygraphviz/): HTTP Error 404: Not Found
  Will skip URL http://networkx.lanl.gov/wiki/download when looking for download links for pygraphviz
  Could not fetch URL http://networkx.lanl.gov/wiki/download (from http://pypi.python.org/simple/pygraphviz/): HTTP Error 404: Not Found
  Will skip URL http://networkx.lanl.gov/wiki/download when looking for download links for pygraphviz
  Could not fetch URL http://sourceforge.net/project/showfiles.php?group_id=122233&package_id=161979 (from http://pypi.python.org/simple/pygraphviz/): HTTP Error 404: Not Found
  Will skip URL http://sourceforge.net/project/showfiles.php?group_id=122233&package_id=161979 when looking for download links for pygraphviz
  Could not fetch URL http://sourceforge.net/project/showfiles.php?group_id=122233&package_id=161979 (from http://pypi.python.org/simple/pygraphviz/): HTTP Error 404: Not Found
  Will skip URL http://sourceforge.net/project/showfiles.php?group_id=122233&package_id=161979 when looking for download links for pygraphviz
  Downloading pygraphviz-0.99.1.zip (96Kb): 96Kb downloaded
  Running setup.py egg_info for package pygraphviz
    Trying pkg-config
    library_path=
    include_path=/usr/include/graphviz
    warning: no files found matching ‘*.edgelist’ under directory ‘examples’
    warning: no files found matching ‘*.mbox’ under directory ‘examples’
    warning: no files found matching ‘*.bz2’ under directory ‘examples’
    warning: no files found matching ‘*.png’ under directory ‘doc’
    warning: no previously-included files matching ‘*~’ found anywhere in distribution
    warning: no previously-included files matching ‘*.pyc’ found anywhere in distribution
    warning: no previously-included files matching ‘.svn’ found anywhere in distribution
    no previously-included directories found matching ‘doc/build’
Installing collected packages: pygraphviz
  Running setup.py install for pygraphviz
    Trying pkg-config
    library_path=
    include_path=/usr/include/graphviz
    building ‘pygraphviz._graphviz’ extension
    gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/graphviz -I/usr/include/python2.5 -c pygraphviz/graphviz_wrap.c -o build/temp.linux-i686-2.5/pygraphviz/graphviz_wrap.o
    gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions build/temp.linux-i686-2.5/pygraphviz/graphviz_wrap.o -lcgraph -lcdt -o build/lib.linux-i686-2.5/pygraphviz/_graphviz.so
    warning: no files found matching ‘*.edgelist’ under directory ‘examples’
    warning: no files found matching ‘*.mbox’ under directory ‘examples’
    warning: no files found matching ‘*.bz2’ under directory ‘examples’
    warning: no files found matching ‘*.png’ under directory ‘doc’
    warning: no previously-included files matching ‘*~’ found anywhere in distribution
    warning: no previously-included files matching ‘*.pyc’ found anywhere in distribution
    warning: no previously-included files matching ‘.svn’ found anywhere in distribution
    no previously-included directories found matching ‘doc/build’
Successfully installed pygraphviz

ひよってパッケージ。。。。。

hdknr@LennyOne:~/djopenid/djopenid$ sudo aptitude install python-matplotlib python-matplotlib-data python-matplotlib-doc
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています… 完了
タスクの記述を読み込んでいます… 完了
以下の新規パッケージがインストールされます:
  dvipng{a} libblas3gf{a} libffi5{a} libgfortran3{a} libglade2-0{a} liblapack3gf{a} python-antlr{a} python-cairo{a} python-configobj{a} python-dateutil{a} python-enthought-traits{a} python-excelerator{a} python-gd{a} python-glade2{a} python-gobject{a} python-gtk2{a} python-matplotlib python-matplotlib-data
  python-matplotlib-doc python-numeric{a} python-numpy{a} python-pyparsing{a} python-tz{a}
更新: 0 個、新規インストール: 23 個、削除: 0 個、保留: 0 個。
14.6MB のアーカイブを取得する必要があります。展開後に 47.2MB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] Y

取得:1 http://ftp.jp.debian.org lenny/main dvipng 1.11-1 [84.2kB]
                  /84.2kB 95%]
取得:2 http://ftp.jp.debian.org lenny/main libgfortran3 4.3.2-1.1 [229kB]
1% [2 libgfortran3 128570/229kB 56%]

34.0kB/s 7min1sパッケージを事前設定しています …
未選択パッケージ dvipng を選択しています。
(データベースを読み込んでいます … 現在 69957 個のファイルとディレクトリがインストールされています。)
(…/dvipng_1.11-1_i386.deb から) dvipng を展開しています…
未選択パッケージ libgfortran3 を選択しています。
(…/libgfortran3_4.3.2-1.1_i386.deb から) libgfortran3 を展開しています…
未選択パッケージ libblas3gf を選択しています。
(…/libblas3gf_1.2-2_i386.deb から) libblas3gf を展開しています…
未選択パッケージ libglade2-0 を選択しています。
(…/libglade2-0_1%3a2.6.2-1_i386.deb から) libglade2-0 を展開しています…
未選択パッケージ liblapack3gf を選択しています。
(…/liblapack3gf_3.1.1-1_i386.deb から) liblapack3gf を展開しています…
未選択パッケージ python-antlr を選択しています。
(…/python-antlr_2.7.7-10_all.deb から) python-antlr を展開しています…
未選択パッケージ python-cairo を選択しています。
(…/python-cairo_1.4.12-1.2_i386.deb から) python-cairo を展開しています…
未選択パッケージ python-configobj を選択しています。
(…/python-configobj_4.5.2-1_all.deb から) python-configobj を展開しています…
未選択パッケージ python-dateutil を選択しています。
(…/python-dateutil_1.4.1-2_all.deb から) python-dateutil を展開しています…
未選択パッケージ python-enthought-traits を選択しています。
(…/python-enthought-traits_2.0.5-1_i386.deb から) python-enthought-traits を展開しています…
未選択パッケージ python-excelerator を選択しています。
(…/python-excelerator_0.6.3a-4_all.deb から) python-excelerator を展開しています…
未選択パッケージ libffi5 を選択しています。
(…/libffi5_3.0.7-1_i386.deb から) libffi5 を展開しています…
未選択パッケージ python-gobject を選択しています。
(…/python-gobject_2.14.2-2_i386.deb から) python-gobject を展開しています…
未選択パッケージ python-numeric を選択しています。
(…/python-numeric_24.2-9_i386.deb から) python-numeric を展開しています…
未選択パッケージ python-gtk2 を選択しています。
(…/python-gtk2_2.12.1-6_i386.deb から) python-gtk2 を展開しています…
未選択パッケージ python-glade2 を選択しています。
(…/python-glade2_2.12.1-6_i386.deb から) python-glade2 を展開しています…
未選択パッケージ python-numpy を選択しています。
(…/python-numpy_1%3a1.1.0-3+lenny1_i386.deb から) python-numpy を展開しています…
未選択パッケージ python-gd を選択しています。
(…/python-gd_0.52debian-3.1_i386.deb から) python-gd を展開しています…
未選択パッケージ python-tz を選択しています。
(…/python-tz_2008c-2_all.deb から) python-tz を展開しています…
未選択パッケージ python-matplotlib-data を選択しています。
(…/python-matplotlib-data_0.98.1-1+lenny4_all.deb から) python-matplotlib-data を展開しています…
未選択パッケージ python-pyparsing を選択しています。
(…/python-pyparsing_1.5.0-1_all.deb から) python-pyparsing を展開しています…
未選択パッケージ python-matplotlib を選択しています。
(…/python-matplotlib_0.98.1-1+lenny4_i386.deb から) python-matplotlib を展開しています…
未選択パッケージ python-matplotlib-doc を選択しています。
(…/python-matplotlib-doc_0.98.1-1+lenny4_all.deb から) python-matplotlib-doc を展開しています…
man-db のトリガを処理しています …
doc-base のトリガを処理しています …
Processing 1 added doc-base file(s)…
dvipng (1.11-1) を設定しています …
libgfortran3 (4.3.2-1.1) を設定しています …
libblas3gf (1.2-2) を設定しています …
libglade2-0 (1:2.6.2-1) を設定しています …
liblapack3gf (3.1.1-1) を設定しています …
python-antlr (2.7.7-10) を設定しています …
python-cairo (1.4.12-1.2) を設定しています …
python-configobj (4.5.2-1) を設定しています …
python-dateutil (1.4.1-2) を設定しています …
python-enthought-traits (2.0.5-1) を設定しています …
python-excelerator (0.6.3a-4) を設定しています …
libffi5 (3.0.7-1) を設定しています …
python-gobject (2.14.2-2) を設定しています …
python-numeric (24.2-9) を設定しています …
python-gtk2 (2.12.1-6) を設定しています …

python-glade2 (2.12.1-6) を設定しています …
python-numpy (1:1.1.0-3+lenny1) を設定しています …
pycentral: pycentral pkginstall: not overwriting local files
pycentral pkginstall: not overwriting local files
dpkg: python-numpy の処理中にエラーが発生しました (–configure):
サブプロセス post-installation script はエラー終了ステータス 1 を返しました
python-gd (0.52debian-3.1) を設定しています …
python-tz (2008c-2) を設定しています …
python-matplotlib-data (0.98.1-1+lenny4) を設定しています …
python-pyparsing (1.5.0-1) を設定しています …
dpkg: 依存関係の問題により python-matplotlib の設定ができません:
python-matplotlib は以下に依存 (depends) します: python-numpy (>= 1:1.1.0) …しかし:
  パッケージ python-numpy はまだ設定されていません。
dpkg: python-matplotlib の処理中にエラーが発生しました (–configure):
依存関係の問題 – 設定を見送ります
python-matplotlib-doc (0.98.1-1+lenny4) を設定しています …
python-support のトリガを処理しています …
以下のパッケージの処理中にエラーが発生しました:
python-numpy
python-matplotlib
E: Sub-process /usr/bin/dpkg returned an error code (1)
パッケージをインストールできませんでした。復旧を試みています:
python-numpy (1:1.1.0-3+lenny1) を設定しています …
pycentral: pycentral pkginstall: not overwriting local files
pycentral pkginstall: not overwriting local files
dpkg: python-numpy の処理中にエラーが発生しました (–configure):
サブプロセス post-installation script はエラー終了ステータス 1 を返しました
dpkg: 依存関係の問題により python-matplotlib の設定ができません:
python-matplotlib は以下に依存 (depends) します: python-numpy (>= 1:1.1.0) …しかし:
  パッケージ python-numpy はまだ設定されていません。
dpkg: python-matplotlib の処理中にエラーが発生しました (–configure):
依存関係の問題 – 設定を見送ります
以下のパッケージの処理中にエラーが発生しました:
python-numpy
python-matplotlib
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています… 50%
��ています
状態情報を読み取っています… 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています… 完了
拡張状態情報を書き込んでいます… 完了
タスクの記述を読み込んでいます… 完了

カテゴリー: 未分類 パーマリンク

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中