php: php-curl on Debian Lenny

hdknr@deb09:~/hdknr.vpc/moodle$ grep deb /etc/apt/sources.list
# deb cdrom:[Debian GNU/Linux 4.0 r6 _Etch_ – Official i386 NETINST Binary-1 20081220-23:12]/ lenny contrib main
#deb cdrom:[Debian GNU/Linux 4.0 r6 _Etch_ – Official i386 NETINST Binary-1 20081220-23:12]/ lenny contrib main
deb http://ftp.jp.debian.org/debian/ lenny main
deb-src http://ftp.jp.debian.org/debian/ lenny main
#deb http://ftp.jp.debian.org/debian/ lenny main non-free contrib
#eb-src http://ftp.jp.debian.org/debian/ lenny main non-free contrib
deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib
hdknr@deb09:~/hdknr.vpc/moodle$ apt-cache search curl | grep php
php5-curl – CURL module for php5
hdknr@deb09:~/hdknr.vpc/moodle$ sudo aptitude install php5-curl
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています… 完了
タスクの記述を読み込んでいます… 完了
以下の新規パッケージがインストールされます:
  libcurl3{a} libidn11{a} libssh2-1{a} php5-curl
更新: 0 個、新規インストール: 4 個、削除: 0 個、保留: 0 個。
457kB のアーカイブを取得する必要があります。展開後に 1081kB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] y
拡張状態情報を書き込んでいます… 完了
取得:1 http://ftp.jp.debian.org lenny/main libidn11 1.8+20080606-1 [141kB]
取得:2 http://ftp.jp.debian.org lenny/main libssh2-1 0.18-1 [64.3kB]
取得:3 http://ftp.jp.debian.org lenny/main libcurl3 7.18.2-8 [227kB]
エラー http://ftp.jp.debian.org lenny/main php5-curl 5.2.6.dfsg.1-0.1~lenny1
  404 Not Found [IP: 133.87.45.30 80]
433kB を 21s 秒でダウンロードしました (19.7kB/s)
未選択パッケージ libidn11 を選択しています。
(データベースを読み込んでいます … 現在 57343 個のファイルとディレクトリがインストールされています。)
(…/libidn11_1.8+20080606-1_i386.deb から) libidn11 を展開しています…
未選択パッケージ libssh2-1 を選択しています。
(…/libssh2-1_0.18-1_i386.deb から) libssh2-1 を展開しています…
未選択パッケージ libcurl3 を選択しています。
(…/libcurl3_7.18.2-8_i386.deb から) libcurl3 を展開しています…
libidn11 (1.8+20080606-1) を設定しています …
libssh2-1 (0.18-1) を設定しています …
libcurl3 (7.18.2-8) を設定しています …
E: http://ftp.jp.debian.org/debian/pool/main/p/php5/php5-curl_5.2.6.dfsg.1-0.1~lenny1_i386.deb を取得できませんでした: 404 Not Found [IP: 133.87.45.30 80]
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています… 完了
拡張状態情報を書き込んでいます… 完了
タスクの記述を読み込んでいます… 完了

ということで、php5-curlが落ちません。 updateが必要でしたね。update後、lenny2になったところインストールできました。

hdknr@deb09:~/hdknr.vpc/moodle$ sudo aptitude install php5-curl
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています… 完了
タスクの記述を読み込んでいます… 完了
以下の新規パッケージがインストールされます:
  libcurl3{a} libidn11{a} libssh2-1{a} php5-curl
更新: 0 個、新規インストール: 4 個、削除: 0 個、保留: 0 個。
アーカイブ 457kB 中 23.7kB を取得する必要があります。展開後に 1081kB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] y
拡張状態情報を書き込んでいます… 完了
取得:1 http://ftp.jp.debian.org lenny/main php5-curl 5.2.6.dfsg.1-1+lenny2 [23.7kB]
23.7kB を 4s 秒でダウンロードしました (4839B/s)
未選択パッケージ libidn11 を選択しています。
(データベースを読み込んでいます … 現在 57343 個のファイルとディレクトリがインストールされています。)
(…/libidn11_1.8+20080606-1_i386.deb から) libidn11 を展開しています…
未選択パッケージ libssh2-1 を選択しています。
(…/libssh2-1_0.18-1_i386.deb から) libssh2-1 を展開しています…
未選択パッケージ libcurl3 を選択しています。
(…/libcurl3_7.18.2-8_i386.deb から) libcurl3 を展開しています…
未選択パッケージ php5-curl を選択しています。
(…/php5-curl_5.2.6.dfsg.1-1+lenny2_i386.deb から) php5-curl を展開しています…
libidn11 (1.8+20080606-1) を設定しています …
libssh2-1 (0.18-1) を設定しています …
libcurl3 (7.18.2-8) を設定しています …
php5-curl (5.2.6.dfsg.1-1+lenny2) を設定しています …
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています… 完了
拡張状態情報を書き込んでいます… 完了
タスクの記述を読み込んでいます… 完了

カテゴリー: 未分類 パーマリンク

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中